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Introduction

About This Manual

This manual applies to the DM Alarms Performance Monitor add-on for version 8.2x of the Imecom Use it
Messaging ™ DM Fax Server™ software. This manual is intended for use as a guide for installing and
configuring the DM Alarms Module.

Additional Imecom Documentation and Manuals are located on your Imecom CD or on our website
http://www.imecominc.com/support/manuals/.

Copyright Notice

© 2009 IMECOM GROUP, Inc. All rights reserved. No part of this document may be reproduced,
transmitted, transcribed, or translated into any language in any form by any means without the written
permission of Imecom Group, Inc.

Imecom, the Imecom logo, DM Alarms, Use it, Use it Suite, Use it Messaging, DM, DM Server, DM Fax
Server, DM Controller, DM Processing Unit, DM Fax Gateway are registered trademarks of Imecom Group,
Inc. and Prologue Software Group.

All other company, brand and product names are the property, trademarks, or registered trademarks of
their respective holders.

The information contained in this document is subject to change without prior notice. Unless expressly
stated to the contrary, the companies, names and data used in the examples are purely fictitious.

For More Information

Since 1989, Imecom Group has been providing enterprise fax server solutions, network fax software, and
image printer driver software to companies or all sizes across the world. For more information on Imecom
Group and our product offerings, please visit http://www.imecominc.com or call us at +1 603.569.0600.

Imecom Group, Inc.

8 Governor Wentworth Highway
Wolfeboro, NH 03894

U.S.A.

Phone: 603.569.0600

Fax: 603.569.0609
http://www.imecominc.com
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Before You Begin

Overview

The operational reliability of computer solutions is critical for today’s companies. Hardware and software
components should be advanced and dependable, but there should also be methods for warning of and
solving malfunctions. With this in mind, Imecom designed the DM Alarms Module.

DM Alarms is based on Windows NT counter and event-log technology. It automatically generates alarms
and takes corrective actions when the threshold limit for a monitored counter is reached or when a
particular event is logged.

Main Features
There are 3 parts to DM Alarms:

1.

Detect a alarm condition

DM Alarms detects alarm conditions using one of two methods:

- By periodically reading the values of NT "counters", on any machine on the network.
- By monitoring events in the local NT Event Log.

Notify

When an alarm condition is detected, DM Alarms can log, and/or warn one or more
administrators of the error condition. Warning messages sent by DM Alarms are called
notification messages. These can be sent via:

- Windows Messaging pop-up messages

- An email system (using MAPI or SMTP)

- SNMP traps

- SMS Messaging

Take a corrective action

When an error condition is detected, DM Alarms can be configured to perform the following
tasks:

- Stop, start, or re-start any NT service on any computer

- Restart a system

- Execute a program or a batch file

Each set of such elements (Alarm condition + Notification + Corrective action) is called a Supervision rule.
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Components of DM Alarms

The three main components of DM Alarms are:
1.The DM Alarms service
2.The administration application
3.The configuration database

DM Alarms Service

The DM Alarms service is the program file IFSPVSVC.EXE. It is an NT service that runs on Windows
2008/2003/2000. It performs the tasks of detecting error conditions, notifying and taking corrective
actions.

Administration Application

The administration application is the program file IFSPVADM.EXE. It allows you to create and configure
supervision rules and, more specifically, to define the instances (services or applications) to be monitored,
the warnings to be issued and the corresponding actions to be taken. All these rules, called “Supervision
Rules”, are saved in the database.

Service Configuration Database

The IFSPV.MDB database is accessed through ODBC functions. It can be installed on any local or Network
(remote) hard disk of the machine. All the information requested by the DM Alarms service is contained in
this database. They are read each time the DM Alarms service is restarted.

General Prerequisites
The prerequisite for installing the Imecom DM Alarms Module is as follows:

e Microsoft’s Data Access Components module (MDAC) must be installed on the machine(s) where

the DM Alarms administration and service will run. On Windows 2000 and higher, MDAC is
already installed with the base Operating System.
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1. Installation of DM Alarms

The procedure for a new installation of the Imecom DM Alarms Module is a simple one. This guide

assumes that the installation process is performed on a machine running the Imecom DM Fax Server
software.

Copying the Setup files

It is first necessary to copy the DM Alarms setup files to the existing Imecom directory structure. These
setup files may be located in a downloadable package from Imecom, or located on your Imecom CD.

From Download Package
1. Download the DM Alarms package from the Imecom Group website. (Contact your sales
representative to obtain instructions for doing this).

2. Unzip the downloaded file to a temporary directory on the fax server machine.

3. From the temporary directory, run the setup.exe file located in the Alarms\i386 directory. This
will launch a short setup process whereby the DM Alarms setup files will be copied to the existing
Imecom directory structure.

4. Proceed through this short setup process, clicking Next several times until setup is complete.

From the Imecom CD

1. Using Windows Explorer, browse the contents of the Imecom CD and locate the “Alarms” folder.

2. Run the setup.exe file located in the Alarms\i386 directory. This will launch a short setup process
whereby the DM Alarms setup files will be copied to the existing Imecom directory structure.

3. Proceed through this short setup process, clicking Next several times until setup is complete.

Installing DM Alarms

Once the setup files have been copied to the Imecom directory structure, you may now install DM Alarms.

1. Click Start > All Programs > Imecom DM and choose “Install_Uninstall Services”. This launches the
main Imecom DM Fax Server setup process.

O You may also run the Imecom DM Fax Server setup process by running setupsvr.exe located in
the Imecom\IFBIN\I386 directory.
INFO
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2.  When setup reaches the “Services Installation/Uninstallation” dialog box, tick the checkbox next
to DM Alarms, and click Next.

B Use it Messaging - Services Installation/Uninstallation =10 x|

Use it Messaging - Services Installation/Uninstallation il
E ® | Local installation directary For services : I CHFIRMAR
Shared directory For Imecom programs I VDELL-MOTEMWetRookPathg

- Toinstall an option, check the corresponding checkbo,
- To remove an option, uncheck the corresponding checkbos,

—Services

—Docurnent Messaging Server
v DI Server Controller

W DM Server Processing Unik

v DM alarms

—Fax Gateway
¥ Services

r N Application Conmeckar
™ oM archives

™ D wweb Client

I™ | Gutlsok Enbancements

= Previous | Mext = I ik

3. Proceed through the remainder of the setup process until it completes.

When setup has completed, you will see a new item in the Imecom DM Start Menu program group called
Admin-DM Alarms. Click this to configure DM Alarms.
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2. DM Alarms Administration Overview

To launch the DM Alarms Administration, click Start > All Programs > Imecom DM and select Admin-DM
Alarms.

Understanding the Main Administration Window

§: Supervision administration - DELL-NOTE — |EI|5|
Eile Edit Tools 2

=] il 1 2

EE Monikered equipment(s) Properky I Walue
E| DELL-pOTE | Matification -------

; MWT event and message fes

EQ{, ?m{ecum - iZonneckar: 0 . MAPT message Mo
B{Bessages - aborted <=1 { 0.000) SMMP Trap Mo

@, Irecom - Conneckor: 1 Running a pragram Mo

@, Imecom - Conneckar: 2 SMTP emai Ma

M3 message Mo

Action

Mo ackion confiqured

100
75
L0
25
0
| &
The Administration program main window has 2 or 3 panes, depending on what is selected.
The left pane is a “Tree-view” that lists the supervision rules, sorted by:
e Monitored equipment
e Log: Source
e Counter or Event.
;’ The administration program does not carry out notifications or corrective actions. The service
= does. Hence, it is possible for the administration program to detect an error condition, and yet

NOTE for no notification or corrective action to take place, (until such time as the service detects
that same error condition).
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The upper right pane is visible only when a “lowest level”
or an Event). It displays the main parameters of that supervision rule.

item is selected in the left pane (i.e. a Counter

The lower right pane shows a graph view of the monitored counter value.

There are four (4) menu items across the top of the DM Alarms Administration interface:

e  File: Under the file menu, you can open a new computer to monitor, apply supervision rules,
view supervision properties, and exit DM Alarms.

e Edit: Under the edit menu, you can add, modify,

and delete supervision rules.

e Tools: Under the tools menu, you can view the system Event Log.

e Help (?): Under the help menu, you can view information about DM Alarms, help on DM Alarmes,

and view/update your specific license for DM Alarms.

Licensing DM Alarms

By default, DM Alarms installs with a 30-day demo license. You may upgrade from a demo license to a
production license by purchasing a DM Alarms license from an Imecom sales representative.

The DM Alarms license nay be updated from the main DM Alarms Administration program.

1. From the ? menu, choose License.

{' Superyision module - Licence Managemenk

B
L o

Supervision module
Licence Management
Copyright @ 1989-2009 Imecom Group

Company)
I Humber

Type
Ualue

State
Options

: DEHMO

: @A0CC-088Z2C-2UB12-AN2008
: Time

T 312720089

: Valid

Ipdate | (04 I

2. The current license information is displayed in the License management window. To update your

license, click the Update button.
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upervision module - Licence Managemenk

Camparny

Reqistration Mumber
| : - | - |l
04 I Cancel |

3. Enter the Company and Registration Number information supplied to you by an Imecom
representative.

4. Click OK.

A dialog box will pop up indicating either a successful license update or an error. If there is an error, check
to make sure your license information is entered correctly.
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3. Configuring DM Alarms

Create a Supervision Rule

To create a supervision rule you must configure the following:

e The counter or event being monitored
e Any notification (optional)
e Any correction action (optional)

1. Inthe Supervision Administration window, select Add from the Edit menu in order to identify
the equipment (computers) for which the services are to be monitored.

Monitaring | Motification | action | Chart |

Alarm or: IEuunters
¥ Enable

v Display anly the objects, instances and counters IMECOM

=

Computer: |pE| | -NOTE

Object:

(ol y | <, Erriors Receiving Faxes
% Errors Sending Faxes
% Faxes Received Ok

% Faxes Senkt OF
Disabled Fax Ling

Line Status

—alert if:

%" Below or equal ko

= pbove I':'—

Caption: I

j_l Explain. .. :=-;=.|

s

2
3
4

—Maonitaring parameters:
¥ Stop once triggerec  Wumber of checks: Iz

i Conkinuous

Every: I 10 second(s)

Add LCancel

2. If you wish to use a Log Event as an error condition, skip to step 9. If you wish to use an NT
counter value as an error condition, from the “Alarm On” drop-down list, choose “Counters” and

tick the “Enable” checkbox.

3. Inthe Computer field of the Monitoring tab, select the server running the services which are to
be monitored. By default the name of the server on which the Alarms administration module has
been installed appears in this field. Use the Browse button to access the network to select

another computer.

4. Select the type of object. There can be multiple Instances of an object, or none. There are
counters for each instance, or for the object if it doesn’t have instances.
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5. If necessary, select the relevant instance in the Instances field. After selecting the service
(instance), the Counter field displays a list of the counters available for this service.

6. Select the required counter then fill in the fields in the Alert if box.

a. Above : Check this option if you want the alarm to sound when the value is greater than
(>) that indicated.

b. Below or equal: Check this option if you want the alarm to sound when the value is less
than or equal to (<=) that indicated.

7. If necessary, enter a caption to identify the rule you are defining. A caption is already provided
for the Elapsed Time counter.

8. Fill in the Monitoring parameters field.

a. Stop once triggered: Select this option if you want the notification and corrective
actions to take place only once. In this mode, the supervision rule must be “rearmed” to
be active again. It is rearmed automatically when the monitored counter no longer
meets the error condition.

b. Continuous: Select this option if you want the notification and corrective actions to take
place as long as the error condition is met. When the alarm type is set to Continuous, no
restart or notification actions are authorized so as to avoid messages being sent
continuously.

c. Number of attempts: Only available if the Stop once triggered option is checked. Enter
the number of times the monitored counter value must be under or above the threshold
in order for the alarm to be triggered.

d. Time interval (in seconds): Time interval between each reading of the counter. 8. If you
wish to suspend this alarm temporarily, uncheck the Active box. When this box is
unchecked, the Supervision Administration window becomes inactive.

9. |If you just configured the error condition using an NT counter, skip to step 11. If you wish to use a
Log Event as an error condition, from the ‘Alarm On” drop-down list box, choose “Event Log” and
tick the “Enable” checkbox.

10. Fill in the required fields:
a. Log: Select the log in which DM Alarms is to detect the event that comprises the error
condition (Application log, Security log or System log).
Source: Select the source for the event that comprises the error condition.
Type: Select the type of event that comprises the error condition.

Number of event(s): Enter the event numbers that comprise the error condition.

A

Restore message: Check this box to retrieve the event log text for the event, and paste
it into the modification message. The monitoring parameters have now been set.

11. At this pointin the procedure you can:
a. Specify the notification or restart parameters by clicking the relevant tabs, or

b. Save the rule and return to the Supervision Administration window by clicking the Add
button and then OK to confirm that you wish to create a new supervision rule.

If you wish to view all the supervision rules which have been created before continuing, click Add then
Done buttons to return to the Supervision Administration window.
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The name of the monitored equipment appears in the left half of the window. For each of the items listed
you can expand the tree structure in order to display the monitored processes.

You can expand the tree structure by a further level by clicking each process in order to display the
monitored counters.

When you select a supervision rule in the left half of the window, a summary of its monitoring parameters
is displayed in the right half of the window.

If an alarm is triggered, the icon which appears before the name of the supervision rule causing the alarm
is replaced with a different icon = a blinking light bulb icon.

Create Notification Actions
After creating the supervision rule, you can configure a notification. Notifications ca be configured when

creating a supervision rule after you have specified the error condition, or in the Supervision
Administration window by selecting the relevant rule and clicking Modify in the Edit menu. These
instructions assume the latter.

1. Inthe Supervision Administration window, from the Edit menu, click Modify.

2. Click the Notification tab.

bonitoring  Matification |.~’-‘-.u:tiu:|n| Chart |

Type of notification when detecting an alarm caonditian:

BWHT event and mess:

[MAPI meszage

[]SMMP Trap

[JRunning a program

[ISMTP email |

NT | M&Pl | SNMP | Program | SMTP| SMs |

™| Logevent Tivpe: IErru:ur 'I

—Metwork alerk:

™| Send|a network message,
Computeris
DELL-MOTE ficld
Delete |
[Message:

Add LCancel
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3. Select the type(s) of mail systems to use for sending the alert messages:

a. NT event and message

b. MAPI message (Only available for "one shot" type alarms)
c. SNMP alert

d. Running a program

e. SMTP e-mail

f.

SMS message

4. Select and configure one or more notification option(s).
5. When the notification parameters have been specified, you can:

a. Specify the Corrective action parameters for this supervision rule by clicking the
corresponding tab, or

b. Save the rule and return to the Supervision Administration window by clicking the Add
button.

At this point, a screen appears, confirming that you have successfully added a new supervision rule. Click
OK.
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Sending alerts via a Windows pop-up message

Maritoring ~ Motification |.~’-‘-.u:tiu:|n| Chart |

Type of natification when detecting an alarm canditiaon:

[IMAPI meszage

[]SHMP Trap

[ |Running a program

[JSMTP email |

NT | M&PI | SNMF | Program | SMTF| SMS |

V¥ Log event A arning
—Metwaork alert:
¥ Send a network message.
Computeris):
Add
Delete |
Message:

[ ]

Cancel

1. Inthe NT tab, check the option Log event if you want the event to be reported in the Windows

NT Event Log.

2. Fill in the Network Alert area:

e Send a network message: Check this option if you wish to send an NT pop-up message

to one or more workstations.

e Computer(s): Click the Add button to add the name of the computers selected to

receive the alert message to the Computer(s) field.

e Message: Enter a relevant text message describing the alarm in question.
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Sending alerts via MAPI mail system

Maritoring ~ Motification |.fi‘-.|:tiu:|n| Chart I

Type of natification when detecting an alarm canditiaon:

[IMAPI meszage

[]SMMP Trap

[ JRunning a program

[ISMTP email |

NT | M&Pl | SNMP | Program | SMTP| SMs |

¥ Log event e El ST
—Mebwork alert:
IV Send a network message.
Computeris):
Aidd
Delete
Message:

(] I Cancel

9.

O N o u

Select the MAPI tab.
Click the browse button to choose the recipient(s) of the alert message

The first time you make an entry, and if the two fields (Profile and Password) of the Connection
area are empty, the profile identification box appears.

Enter the name of an existing Profile* of the mail system with which the recipient’s mailbox is
associated.

Enter the password (if any).
Click OK.
The address book is displayed to enable you to select one or more recipients.

Click OK. The Recipient(s) field is now filled in. The name of the profile and, if necessary, its
password, are entered in the Connection area.

Enter the subject of the message.

10. Enter a new alert message or keep the alert message already provided.
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Sending alerts via SNMP

SNMP is a supervision protocol between entities called Agents and Managers. The Agent is the entity
being monitored and/or configured, while the Manager is the application used to monitor or configure
the Agent.

Of the interactions which are possible between the Agent and Manager, the Trap is a specific message
sent by the Agent to the Manager to indicate that a problem has occurred.

In this case, DM Alarms works in association with the Windows SNMP Agent. When the alarm is triggered,
DM Alarms causes the Windows SNMP Agent to send a Trap which can be received and interpreted by
any Manager.

To implement SNMP notification, you must install and configure the Windows SNMP service on the
computer where the DM Alarms service is also installed. Refer to the following setup procedure. It is not
necessary, however, to install the SNMP service on computers running DM Alarms administration.

Setting up SNMP
The Windows SNMP service should be installed on the same computer where the DM Alarms service is
installed.

1. In Control Panel, double-click the Network icon. The Network window appears.

2. Select the Services tab then click the Add... button.

3. Inthe Select Network Service window which appears, select SNMP Service then click OK.
4. Indicate the path to the files required to install the SNMP service.
5

After copying the files, configure the SNMP service. If you have just copied the files, the
Microsoft SNMP Properties window is displayed. If not, in Control Panel double-click the
Network icon, choose the Services tab. Select SNMP Service and then click the Properties
button.

In the Microsoft SNMP Properties window, select the Traps tab.

6

7. Community Name: Enter Public.

8. Trap Destinations: Enter the IP address(es).
9

Click OK.

10. Start the SNMP service via the service manager.

11. Install the SNMP service on the Manager's computer.
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Creating a DM Alarms notification using an SNMP Trap

x|
Maritoring ~ Motification |.~’-‘-.u:tiu:|n| Chart |

Type of natification when detecting an alarm canditiaon:

[IMT event and meszage -
[IMAPI meszage

[ |Running a program
[JSMTP email |

NT | M&Pl  SNMP | Frogram | SMTF| SMS |

oI |1.3.6.1.4.1.39?1.1.1.D
Tvpe: Specific identification
Identification: I o

Message: I

(] I Cancel

1. Select the SNMP tab.
2. Enter a new alert message or keep the alert message already provided.

e OID: Fixed SNMP parameters.
e Type : describing the Traps generated.
e Identification : by the Alarms service.

e Message: User-defined description.
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Running a program

x|
Maritoring ~ Motification | Action | Chart |
Type of natification when detecting an alarm canditiaon:
[IMT event and meszage
[IMAPI meszage
[]SHMP Trap
Running a program
[JSMTP email |
NT | M&PI | SNMP Frogram | SMTF| SMS |
Prograrm:
Parameteris) :
™ Generic Message
[ Message:
Work directory:
OF. I Cancel
1. Select the Program tab.
e  Program: specify a program file to run by clicking on the Brose button.
e  Generic Message: this will send a generic message when the program is launched.
e Message: This will send a user-defined message.
e Work Directory: This is the directory where program output files, if any, are written.
16
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Sending alerts via SMTP

Maritoring ~ Motification |.~’-‘-.u:tiu:|n| Chart |

Type of natification when detecting an alarm canditiaon:

[IMT event and meszage -
[IMAPI meszage

[]SHMP Trap

[ |Running a program

SMTP email

NT | M&PI | SNMP | Program SMTF | SMs |

Conneckiaon
Eru:um:l Server address: I
To: I Port: I o5
Message
Sthect:I
Texk:

[ ]

Cancel

1. Select the SMTP tab.

e  From: enter email address of the account used to send the notification.

e To: enter recipient email address.

e Server address: enter the IP address of the SMTP server.

e Port: enter the port used by the SMTP server. Port 25 is the default.

e Subject: SMTP notification message subject.
e Text: SMTP notification message body.
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Sending alerts via SMS

Maodify X
Maritoring ~ Motification | Action | Chart |
Type of natification when detecting an alarm canditiaon:

[IMAPI meszage ;I
[]SMMP Trap
[JRunning a program

NT | M&FI | SNMF | Program | SMTF SMS |

Redgert il | I Sdministration. .. |

Sender name I

—Message

Subject ; |

Text ;l

(] I Cancel

1. Select the SMS tab

e Recipient number: number of recipient SMS device.
e Sender name: name of sender.
e Subject: SMS notification message subject.

e  Text: SMS notification message body.
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Creating Corrective Actions
After having defined the error condition, and optionally a notification for a supervision rule, you can
specify a corrective action to be undertaken by DM Alarms. Possible corrective actions include:

e  Stop, start, or restart a service

e Execute a program

e Restart a system

Multiple corrective actions can be combined. In that case, it is possible to specify:
e The order in which the corrective actions should be attempted.

e When to continue with the next corrective action (i.e. always, only when the preceding
corrective action has failed or only when the preceding corrective action has succeeded).

e The wait period before proceeding with the next corrective action.

When creating a supervision rule, after you have specified the error condition, or in the Supervision
Administration window, after selecting the relevant rule and clicking Modify from the Edit menu, click the
Action tab.
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Stop, start, or restart a service

x|

Mu:unitnringl Matification  Action | Chart |

Wwhen detecting an alarm condition: Aften Action on a senvice

M &chion on a service 1 /it II:I seconds
[ |E=ecute a program And cortinue: ¢~ Always
[|Restart spstem Order =

) | success

il % [ failure

Service | F'ru:ugraml S_l,lStemI

Computer: | DELL-NOTE o]
Service: I.NET Runtime Optimization Service VE.D.SDj
Action:

{= Stark serwvice,
[ Stop service First if it is already running

I | Stop service process iF operation Failed
" stop service.

(] I Cancel

1. Select the Action tab.
2. Check Action on a service.
3. Inthe Service tab in the lower half of the screen, specify the appropriate parameters:

e  Computer: select the computer on which a service will have to be started, stopped or
restarted.

e Service: select the service to start, stop or restart.

e Action: select whether to start or stop the service. If you choose to start the service, you can
check the option “stop service first if it is already running” to allow restarting of the service.

Imecom Manual — DM Alarms 20




Execute a program

Mu:unitnringl Matification  Action | Chart |

Wwhen detecting an alarm condition:

[|Action aon a service

E=ecute a program
[|Restart spstem

Service FProgram | S_l,lStemI

Prograrn:

1

Order

a

— After Execute a pragram——————

W it I':I zeconds

And continue; £ Bliays

) | success
% [ failure

Parameteris):

Direckory:

|
[ wait: I_ secondis)

(] I Cancel

1. Select the Action tab.

2. Check Execute a program.

3. Inthe Program tab in the lower half of the screen, specify the appropriate parameters:

e  Program: enter the path and file name of the program file or batch file to run.

Parameter(s): enter any command line parameters to be passed to the program.

e Directory: select the working directory for the program.

e Wait: specify a wait period in seconds.

4. When all corrective actions for this rule have been configured, click Add.
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Restart a system

Please note that this corrective action only applies to the local machine (i.e. the machine where the DM
Alarms service is running)

Mu:unitnringl Motification  Action | Chart |

Wwhen detecting an alarm condition:

[|Action on a service 1 |
[|E=ecute a program
Flestart spstem

Service I Frogram  Sistem

Message to be displayed before restart DELL-MOTE:

= Aifter Hestart spstenm

Wit IEI zeconds

And continue; £ Bliways

0 | success
= ([ failure

|
Delay: W secondis)

[ kill applications after the end of delay

X|

(] I Cancel

1. Select the Action tab.

2. Check Restart system.

3. Inthe System tab in the lower half of the screen, specify the appropriate parameters:

¢ Message to be displayed...: enter a string of text to be displayed in a dialog box before the

computer is rebooted.

e Delay: select the time DM Alarms should wait once the above message is displayed before

proceeding to reboot.

¢ Kill applications after the end of delay: Check this option if you wish DM Alarms to kill any
running task remaining once the above mentioned delay has expired.

4. When all corrective actions for this rule have been configured, click Add.

‘;’ It is possible to configure multiple actions. To do this, check each action to be executed and
= configure each action. When configuring multiple actions involving Action on a service, you

NOTE may specify additional parameters such as wait time and action triggers that apply to the

action that follows the Action on a service.
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Changing an Existing Supervision Rule
1. Completely expand the tree structure of the Supervision Administration window.

2. After choosing the required rule, select Modify from the Edit menu.

3. Make the necessary changes. Refer to the previous section of this chapter for information on
administration of DM Alarms.

4. Click OK.
5. Select Apply from the File menu.

Deleting a Supervision Rule
1. Completely expand the tree structure in the Supervision Administration window.

2. After choosing the required rule, select Delete from the Edit menu.

3. Adialog box appears asking you to confirm that you wish to delete a supervision rule.
4. Click OK.
5

Select Apply from the File menu.

Using Graphs
When creating a Supervision Rule with an error condition based on a counter value, it is possible to add a
graph representation of that counter. Graphs may be configured when creating a supervision rule based
on a counter value, after you have specified the error condition, or in the Supervision Administration
window.

1. Completely expand the tree structure in the Supervision Administration window.

2. Click Modify from the Edit menu.
3. Click the Chart tab.
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4. Check the Active checkbox.
5. Specify the appropriate parameters for the graph:

e Color: select the color to use to represent this counter value in the graph.
e Scale: select the scale at which to display the counter value in the graph.

¢ Time Interval: select the time interval at which to refresh the graph with current counter
values.
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4. Imecom Documentation and Support

Documentation for the Imecom DM Fax Server, DM Connectors and Modules, and Imecom client
components is in PDF format and located in the Documentation folder on the Imecom CD.

All Imecom manual sand guides can also be viewed and downloaded from the Imecom Group, Inc. Web
site at: http://www.imecominc.com/support/manuals.shtml

Technical Support Services

Imecom Group provides technical support services to each customer that has purchased an annual
Imecom Support Plan. Technical support services are provided via telephone, email, and remote
connection to the DM Fax Server.

In addition, the Support section of the Imecom Group, Inc. Web site contains a wealth of information on
Imecom products, product support, announcements, FAQs, and more. The Support section is located at:
http://www.imecominc.com/support/

Onsite Installation and Training Services

Imecom Group, Inc. offers onsite installation and training services to customers requiring such services.
Imecom Group’s skilled engineers are experts in designing, implementing, deploying into production, and
upgrading the Imecom product range. Imecom Onsite Installation and Training Services can speed
integration and deployment Imecom products into your organization and environment.

Contact Imecom Group, Inc.

U.S. Headquarters Sales & General Support

Imecom Group, Inc. Phone: 603.569.0600 Phone: 603.569.0600

8 Governor Wentworth Hwy Fax: 603.569.0609 Fax: 603.569.0609
Wolfeboro, NH 03894 imecomsales@imecominc.com igisupport@imecominc.com
U.S.A.

http://www.imecominc.com
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